using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:http|ftp)s?:\/\/([\w][^\/=\s]+)\/?|(^w{3}[\.\w][^\/\=\s]{2,})\/?";
string input = @"www.google.com.edu-hjj+oio?/kjhkh.txt hjjh
https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7
http://www.yahoo.comhttp://www.yahoo.co
www.foo.com.ui/=hjg.hhj
ggfhgfhfhf.uui
https://regex101.com/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}