package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:http|ftp)s?:\/\/([\w][^\/=\s]+)\/?|(^w{3}[\.\w][^\/\=\s]{2,})\/?`)
var str = `www.google.com.edu-hjj+oio?/kjhkh.txt hjjh
https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7
http://www.yahoo.comhttp://www.yahoo.co
www.foo.com.ui/=hjg.hhj
ggfhgfhfhf.uui
https://regex101.com/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}