import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:http|ftp)s?:\\/\\/([\\w][^\\/=\\s]+)\\/?|(^w{3}[\\.\\w][^\\/\\=\\s]{2,})\\/?";
final String string = "www.google.com.edu-hjj+oio?/kjhkh.txt hjjh\n"
+ "https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7\n\n"
+ "http://www.yahoo.comhttp://www.yahoo.co\n\n\n"
+ "www.foo.com.ui/=hjg.hhj\n"
+ "ggfhgfhfhf.uui\n"
+ "https://regex101.com/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}