# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:http|ftp)s?:\/\/([\w][^\/=\s]+)\/?|(^w{3}[\.\w][^\/\=\s]{2,})\/?"
test_str = ("www.google.com.edu-hjj+oio?/kjhkh.txt hjjh\n"
"https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7\n\n"
"http://www.yahoo.comhttp://www.yahoo.co\n\n\n"
"www.foo.com.ui/=hjg.hhj\n"
"ggfhgfhfhf.uui\n"
"https://regex101.com/\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.