import Foundation
let pattern = #"^((?:\w+\s?){1,12}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)