use strict;
my $str = 'w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15';
my $regex = qr/^((?:\w+\s?){1,12}).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";