// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:\w+\s?){1,12}).*").unwrap();
let string = "w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}