using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\w+\s?){1,12}).*";
string substitution = @"$1";
string input = @"w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}