# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:\w+\s?){1,12}).*/$1/gm;t' <<< "w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15"