import Foundation
let pattern = #"<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<div id='right_arm'><img src='images/001.gif' /></div>
<div id='right_af_arm'><img src='images/002.gif' /></div>
<div id='fegh_header'><img src='images/003.gif' /></div>
<div id='left_paper'><img src='images/004.gif' /></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)