package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>`)
var str = `<div id='right_arm'><img src='images/001.gif' /></div>
<div id='right_af_arm'><img src='images/002.gif' /></div>
<div id='fegh_header'><img src='images/003.gif' /></div>
<div id='left_paper'><img src='images/004.gif' /></div>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}