import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]+id\\s*=\\s*['\"]([^'\"]+)['\"][^>]*>";
final String string = "<div id='right_arm'><img src='images/001.gif' /></div>\n\n"
+ "<div id='right_af_arm'><img src='images/002.gif' /></div>\n\n"
+ "<div id='fegh_header'><img src='images/003.gif' /></div>\n\n"
+ "<div id='left_paper'><img src='images/004.gif' /></div>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}