$re = '/<div[^>]+id\s*=\s*[\'"]([^\'"]+)[\'"][^>]*>/i';
$str = '<div id=\'right_arm\'><img src=\'images/001.gif\' /></div>
<div id=\'right_af_arm\'><img src=\'images/002.gif\' /></div>
<div id=\'fegh_header\'><img src=\'images/003.gif\' /></div>
<div id=\'left_paper\'><img src=\'images/004.gif\' /></div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);