re = /<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>/i
str = '<div id=\'right_arm\'><img src=\'images/001.gif\' /></div>
<div id=\'right_af_arm\'><img src=\'images/002.gif\' /></div>
<div id=\'fegh_header\'><img src=\'images/003.gif\' /></div>
<div id=\'left_paper\'><img src=\'images/004.gif\' /></div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end