use strict;
my $str = '<div id=\'right_arm\'><img src=\'images/001.gif\' /></div>
<div id=\'right_af_arm\'><img src=\'images/002.gif\' /></div>
<div id=\'fegh_header\'><img src=\'images/003.gif\' /></div>
<div id=\'left_paper\'><img src=\'images/004.gif\' /></div>
';
my $regex = qr/<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}