import Foundation
let pattern = #"^((?:\d){1,3}(?:\.\d{1,3}){0,8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 text
1.1 text 2
1.2 text 3
2 text 2
3 text 3
3.1 text 3.1
second string of 3.1
third string of 3.1
4.1.2.3.4.5
4.1.2.3.4.5.6.7.8
//I used .split() method to get multiline text from numbered list
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)