#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:\d){1,3}(?:\.\d{1,3}){0,8})"
Local $sString = "1 text" & @CRLF & _
"1.1 text 2" & @CRLF & _
"1.2 text 3" & @CRLF & _
"2 text 2" & @CRLF & _
"3 text 3" & @CRLF & _
"3.1 text 3.1" & @CRLF & _
"second string of 3.1" & @CRLF & _
"third string of 3.1" & @CRLF & _
"4.1.2.3.4.5" & @CRLF & _
"4.1.2.3.4.5.6.7.8" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//I used .split() method to get multiline text from numbered list"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")