use strict;
my $str = '1 text
1.1 text 2
1.2 text 3
2 text 2
3 text 3
3.1 text 3.1
second string of 3.1
third string of 3.1
4.1.2.3.4.5
4.1.2.3.4.5.6.7.8
//I used .split() method to get multiline text from numbered list';
my $regex = qr/^((?:\d){1,3}(?:\.\d{1,3}){0,8})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}