using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\d){1,3}(?:\.\d{1,3}){0,8})";
string input = @"1 text
1.1 text 2
1.2 text 3
2 text 2
3 text 3
3.1 text 3.1
second string of 3.1
third string of 3.1
4.1.2.3.4.5
4.1.2.3.4.5.6.7.8
//I used .split() method to get multiline text from numbered list";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}