# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:\d){1,3}(?:\.\d{1,3}){0,8})"
test_str = ("1 text\n"
"1.1 text 2\n"
"1.2 text 3\n"
"2 text 2\n"
"3 text 3\n"
"3.1 text 3.1\n"
"second string of 3.1\n"
"third string of 3.1\n"
"4.1.2.3.4.5\n"
"4.1.2.3.4.5.6.7.8\n\n\n"
"//I used .split() method to get multiline text from numbered list")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.