// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)\R["']\s*(OI|OX|OPSIMEX)\s*["'](\S*)["']"#).unwrap();
let string = "\"OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"
\"OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"
\"OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"
\"OX PUBLIC.USER.REXX(EXTREXX)\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}