package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\R["']\s*(OI|OX|OPSIMEX)\s*["'](\S*)["']`)
var str = `"OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OX PUBLIC.USER.REXX(EXTREXX)"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}