import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\R[\"']\\s*(OI|OX|OPSIMEX)\\s*[\"'](\\S*)[\"']";
final String string = "\"OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"\n"
+ "\"OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"\n"
+ "\"OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"\n"
+ "\"OX PUBLIC.USER.REXX(EXTREXX)\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}