using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R[""']\s*(OI|OX|OPSIMEX)\s*[""'](\S*)[""']";
string input = @"""OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'""
""OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'""
""OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'""
""OX PUBLIC.USER.REXX(EXTREXX)""
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}