re = /\R["']\s*(OI|OX|OPSIMEX)\s*["'](\S*)["']/mi
str = '"OX \'EDDMA01.PUBLIC.USER.REXX(EXTREXX)\'"
"OI \'EDDMA01.PUBLIC.USER.REXX(EXTREXX)\'"
"OPSIMEX \'EDDMA01.PUBLIC.USER.REXX(EXTREXX)\'"
"OX PUBLIC.USER.REXX(EXTREXX)"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end