import Foundation
let pattern = #"(http|https|ftp):\/\/(\S*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href=\"$1://$2\">$1://$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)