use strict;
my $str = 'hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi ';
my $regex = qr`(http|https|ftp):\/\/(\S*)`ip;
my $subst = '<a href=\\"$1://$2\\">$1://$2</a>';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";