$re = '`(http|https|ftp):\/\/(\S*)`i';
$str = 'hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi ';
$subst = "<a href=\"$1://$2\">$1://$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;