package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(http|https|ftp):\/\/(\S*)`)
var str = `hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi `
var substitution = "<a href=\"$1://$2\">$1://$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}