import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https|ftp):\\/\\/(\\S*)";
final String string = "hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi ";
final String subst = "<a href=\\\"$1://$2\\\">$1://$2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}