const regex = new RegExp('(http|https|ftp):\\/\\/(\\S*)', 'ig')
const str = `hi https://fillter.me/?asdf=23 hi hi https://fillter.me2/ hi `;
const subst = `<a href=\"$1://$2\">$1://$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);