import Foundation
let pattern = #"(\d{4}-\d{2}-\d{2})-(\d{2}:\d{2}:\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hour
---------------------
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)