using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}-\d{2}-\d{2})-(\d{2}:\d{2}:\d{2})";
string substitution = @"$1 $2";
string input = @" hour
---------------------
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}