# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{4}-\d{2}-\d{2})-(\d{2}:\d{2}:\d{2})"
test_str = (" hour \n"
"---------------------\n"
" 2014-12-06-01:44:35\n"
" 2014-12-06-01:44:35\n"
" 2014-12-06-01:44:35\n"
" 2014-12-06-01:44:35\n"
" 2014-12-06-01:44:35\n"
" 2014-12-06-01:44:35")
subst = "$1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.