import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2})-(\\d{2}:\\d{2}:\\d{2})";
final String string = " hour \n"
+ "---------------------\n"
+ " 2014-12-06-01:44:35\n"
+ " 2014-12-06-01:44:35\n"
+ " 2014-12-06-01:44:35\n"
+ " 2014-12-06-01:44:35\n"
+ " 2014-12-06-01:44:35\n"
+ " 2014-12-06-01:44:35";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}