#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d{4}-\d{2}-\d{2})-(\d{2}:\d{2}:\d{2})"
Local $sString = " hour " & @CRLF & _
"---------------------" & @CRLF & _
" 2014-12-06-01:44:35" & @CRLF & _
" 2014-12-06-01:44:35" & @CRLF & _
" 2014-12-06-01:44:35" & @CRLF & _
" 2014-12-06-01:44:35" & @CRLF & _
" 2014-12-06-01:44:35" & @CRLF & _
" 2014-12-06-01:44:35"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)