package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4}-\d{2}-\d{2})-(\d{2}:\d{2}:\d{2})`)
var str = ` hour
---------------------
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35
2014-12-06-01:44:35`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}