re = /<(?:\s?)[aA].*?href=[\'\"](?<link>.*?)[\'\"].*?>(?<text>.*)<(?:\s?)\/(?:\s?)[aA](?:\s?)>/mi
str = '<a title="" href="asd">Text .432 </ a>
<a href=\'asd\'> Text .432</a>
<a class="asd" hReF="asd\' > T23ext .432 < / A >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end