import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:\\s?)[aA].*?href=[\\'\\\"](?<link>.*?)[\\'\\\"].*?>(?<text>.*)<(?:\\s?)\\/(?:\\s?)[aA](?:\\s?)>";
final String string = "<a title=\"\" href=\"asd\">Text .432 </ a>\n"
+ "<a href='asd'> Text .432</a>\n"
+ "<a class=\"asd\" hReF=\"asd' > T23ext .432 < / A >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}