const regex = /<(?:\s?)[aA].*?href=[\'\"](?<link>.*?)[\'\"].*?>(?<text>.*)<(?:\s?)\/(?:\s?)[aA](?:\s?)>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:\\s?)[aA].*?href=[\\\'\\"](?<link>.*?)[\\\'\\"].*?>(?<text>.*)<(?:\\s?)\\\/(?:\\s?)[aA](?:\\s?)>', 'gmi')
const str = `<a title="" href="asd">Text .432 </ a>
<a href='asd'> Text .432</a>
<a class="asd" hReF="asd' > T23ext .432 < / A >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}