using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:\s?)[aA].*?href=[\'\""](?<link>.*?)[\'\""].*?>(?<text>.*)<(?:\s?)\/(?:\s?)[aA](?:\s?)>";
string input = @"<a title="" href=""asd"">Text .432 </ a>
<a href='asd'> Text .432</a>
<a class=""asd"" hReF=""asd' > T23ext .432 < / A >";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}