package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<(?:\s?)[aA].*?href=[\'\"](?<link>.*?)[\'\"].*?>(?<text>.*)<(?:\s?)\/(?:\s?)[aA](?:\s?)>`)
var str = `<a title="" href="asd">Text .432 </ a>
<a href='asd'> Text .432</a>
<a class="asd" hReF="asd' > T23ext .432 < / A >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}