$re = '/<(?:\s?)[aA].*?href=[\'\"](?<link>.*?)[\'\"].*?>(?<text>.*)<(?:\s?)\/(?:\s?)[aA](?:\s?)>/mi';
$str = '<a title="" href="asd">Text .432 </ a>
<a href=\'asd\'> Text .432</a>
<a class="asd" hReF="asd\' > T23ext .432 < / A >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);