$re = '/((\d+){4})-\1/m';
$str = '1988-1988
1967-1967
1206-2016
2016-2016
1111-1010
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;