const regex = /((\d+){4})-\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d+){4})-\\1', 'gm')
const str = `1988-1988
1967-1967
1206-2016
2016-2016
1111-1010
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);