use strict;
my $str = '1988-1988
1967-1967
1206-2016
2016-2016
1111-1010
';
my $regex = qr/((\d+){4})-\1/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";