#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\d+){4})-\1"
Local $sString = "1988-1988" & @CRLF & _
"1967-1967" & @CRLF & _
"1206-2016" & @CRLF & _
"2016-2016" & @CRLF & _
"1111-1010" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)