using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+){4})-\1";
string substitution = @"\1";
string input = @"1988-1988
1967-1967
1206-2016
2016-2016
1111-1010
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}