# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\d+){4})-\1/\1/gm;t' <<< "1988-1988
1967-1967
1206-2016
2016-2016
1111-1010
"