import Foundation
let pattern = #"""
([^\{\{]++|\{(?!\{))
|
\{\{(\w+)
(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? ) )*
\}\}
((?R)*)
\{\{/\g{-5}\}\}
|
\{\{(\w+)(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? )
)*\}\}
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
{{placeholder name="Alexey"}}
sdasdasda
dasdad
ads
asdasd
sdasd
{{/placeholder}}
<div class="asdasdasd">
{{cssArea}}
{{/cssArea}}
{{escaped open="\"sdfsdf" close='dfdfg'}}
{{/escaped}}
</div>
{{holder name='sadasdas'}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)